Browser and system requirements

We recommend using Microsoft Internet Explorer┬«, version 10, to access Canadian Firearms Program (CFP) web services.

You may be able to access CFP services using other web browsers, but they may not have been fully tested with the CFP's services. If you encounter difficulties, we recommend that you use a different browser.

To ensure that you have uninterrupted access to CFP services, your browser must:

  • support TLS 1.0 or higher (we recommend TLS 1.2)
  • have TLS 1.0 or higher enabled
  • have cookies enabled (please see Terms and conditions for more information on cookies)
  • have JavaScript enabled

If your device is more than five years old, you may encounter difficulties.

We recommend using a Windows-based computer. We cannot provide support for:

  • Internet-enabled mobile devices (including game systems, tablets, and smartphones)
  • Linux devices
  • Apple devices running Mac OS

Note

The Canadian Firearms Program is not responsible for any difficulties or problems with downloading and installing software. Technical support is provided by the software suppliers.

Date modified: