Gendarmerie royale du Canada
Symbole du gouvernement du Canada

Liens de la barre de menu commune

Services en ligne sécurisés du Programme canadien des armes à feu

Exigences relatives au navigateur

Si votre appareil est âgé de plus de cinq ans, il se peut que vous deviez mettre à niveau votre système.

Le Programme canadien des armes à feu (PCAF) effectue la mise à jour régulière de ses services en ligne sécurisés pour s'assurer de profiter de la norme la plus élevée en matière de sécurité, à savoir la norme de chiffrement Transport Layer Security (TLS) 1.2. Le PCAF vous encourage à mettre à niveau votre système à TLS 1.2 pour qu'il soit le plus sécurisé possible.

Il se peut que vous puissiez accéder aux services du PCAF au moyen d'autres navigateurs et d'autres versions lancées récemment des navigateurs que nous prenons en charge. Toutefois, les services du PCAF n'ont pas été mis à l'essai sur ces navigateurs. Si vous éprouvez des difficultés avec ces derniers, nous vous recommandons d'essayer à nouveau au moyen d'un navigateur différent ou d'une version antérieure du même navigateur.

Le PCAF vous encourage fortement d'employer un ordinateur Windows pour accéder correctement à ses services en ligne. Nous ne pouvons pas prendre en charge tous les dispositifs mobiles pouvant accéder à Internet (comme les consoles de jeu, des tablettes et des téléphones intelligents), des appareils de Linux ou des appareils d'Apple équipés des systèmes d'exploitation macOS.

Les services en ligne du PCAF nécessitent un niveau de sécurité qui n'est actuellement pas pris en charge dans tous les navigateurs accessibles sur l'ensemble des différents appareils. Même si vous pourriez avoir accès à certaines fonctions, nous ne pouvons pas résoudre les problèmes que vous éprouvez si vous ne suivez pas nos recommandations.

Remarque :

Le PCAF n'est pas responsable des difficultés ou problèmes qui pourraient survenir lors du téléchargement et de l'installation du logiciel. Le soutien technique est offert par les fournisseurs de logiciels.

Pour vous assurer un accès ininterrompu aux services du PCAF, votre navigateur doit satisfaire aux exigences ci-après:

  • Il doit prendre en charge TLS 1.0 ou une version plus récente (nous recommandons TLS 1.2);
  • TLS 1.0 ou une version plus récente de TLS doit être activée;
  • Il doit accepter les témoins;
  • Il doit accepter le code JavaScript.

Si votre navigateur ne satisfait pas aux exigences susmentionnées, vous devrez activer les témoins, JavaScript et/ou TLS 1.0, 1.1 et 1.2. Si la configuration et les paramètres de votre système ne sont pas compatibles et que vous choisissez de ne pas mettre à niveau votre système ou de ne pas modifier vos paramètres, il se peut que vous ne puissiez pas accéder aux services du PCAF.

Que sont les témoins et de quelle façon sont-ils employés?

Un témoin est un petit fichier texte transmis à votre ordinateur lors de votre entrée dans un site Web. Mis au point pour permettre la conservation de renseignements entre chacune des visites sur un site, les témoins enregistrent vos habitudes de navigation et l'information que vous transmettez.

Vous pouvez régler des paramètres visant à refuser les témoins. Cependant, vous ne pourrez pas obtenir une CléGC ou accéder aux services du PCAF. Si vous choisissez cette option, vous pouvez tout de même accéder aux services du PCAF par téléphone, par télécopieur, par courrier ou en personne.